Please Log-in or Register to get full access to the forums.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] [IE] Error Message: Member not found. [/IE]
27th January, 20:25
Post: #1
[Solved] [IE] Error Message: Member not found. [/IE]
Line: 2552
Character: 4
Code: 0
Error Message: Member not found.

URL: https://ajax.googleapis.com/ajax/libs/jq.../jquery.js


I am not 100% sure qtip is the cause of the error, but I google'd around and it is something about events not working properly in IE or JQuery... so if anyone understands how this can be fixed, I would love to know!

Here is my qtip code!

JS Code
var shared = {
    position: {
        my: 'bottom center', // Position my top left...
        at: 'top center' // at the bottom right of...
 
    },
    style: {
        classes: 'qtip-shadow qtip-light font'
    },
    hide: {
        delay: 250
    },
    show: {
        ready: true
    }
};
 
 
$(document).ready(function () {
 
    $(".thumbnail").hover(function () {
        var info = $(this).attr("data-information").split(",");
        var text = "";
        for (var x = 0; x != info.length; x++) {
            text = text + info[x] + "";
        }
 
        if (info == "" && $(this).qtip("api") !== undefined) {
            $(this).qtip("destroy");
            text = "";
        }
        if (text != "") {
            if ($(this).qtip("api") !== undefined) {
                $(this).qtip('option', 'content.text', text);
            } else {
                $(this).qtip($.extend({}, shared, {
                    content: {
                        text: text
                    }
                }));
            }
        }
    });
 
    $(".productimage").hover(function () {
        var info = $(this).attr("data-information").split(",");
        var text = "";
 
        for (var x = 0; x != info.length; x++) {
            text = text + info[x] + "";
        }
 
        if (info == "" && $(this).qtip("api") !== undefined) {
            $(this).qtip("destroy");
            text = "";
        }
        if (text != "") {
            if ($(this).qtip("api") !== undefined) {
                $(this).qtip('option', 'content.text', text);
            } else {
                $(this).qtip($.extend({}, shared, {
                    position: {
                        my: 'bottom center', // Position my top left...
                        at: 'top center' // at the bottom right of...
 
                    },
                    style: {
                        classes: 'qtip-shadow qtip-light font'
                    },
                    content: {
                        text: text
                    }
                }));
            }
        }
    });
});
Find all posts by this user
Quote this message in a reply
28th January, 04:33
Post: #2
RE: [IE] Error Message: Member not found. [/IE]
*This error also happens here
http://craigsworks.com/projects/qtip2/
Find all posts by this user
Quote this message in a reply
14th May, 08:55
Post: #3
RE: [IE] Error Message: Member not found. [/IE]
Hi, I have been looking at this problem as well.

I believe that you are using IE10, and switching back to IE7 mode, which resulted in this error.
If you try IE9 and switch back to IE7, this does not happen, and qtip does work.

The question is, does the acutal IE7 work?
Find all posts by this user
Quote this message in a reply
21st May, 17:30
Post: #4
RE: [IE] Error Message: Member not found. [/IE]
jQuery bug I'm afraid guys: http://bugs.jquery.com/ticket/12577
Visit this user's website Find all posts by this user
Quote this message in a reply
26th December, 12:05 (This post was last modified: 26th December 12:15 by barong.)
Post: #5
RE: [Solved] [IE] Error Message: Member not found. [/IE]
hi Craig,

first of all I'd like to say thank you for your great work with tooltips plugin!

I have same issue with tooltips in IE11 with IE7 mode (SCRIPT3: Member not found).
If I change all aria- attributes in qtip.min.js file with qtip2aria- for example - it starts work.
But if tooltip position is other then my: "bottom left",at: "top left", one of arrow border doesn't render.

Could you please give me advise how to fix it?
I think arrow borders are rendered, but not visible.

P.S. I have 2px border for tooltip. If I cange it to 1px - it become better, but not perfect.
maybe problem in calculating width and height to show arrow shape.
Find all posts by this user
Quote this message in a reply
30th December, 10:00
Post: #6
RE: [Solved] [IE] Error Message: Member not found. [/IE]
To resolve my problem I included old qtip2 core script (v2.0.1-25- (includes: svg ajax tips modal viewport imagemap ie6 / basic css3)) and I replaced all "aria-" attributes with "data-aria-".

and now it works in IE11 and IE10 with IE7 mode . Not perfect with some tip position, but mostly ok.

Craig, I hope you know how to fix it with the last plugin release.
Find all posts by this user
Quote this message in a reply
30th December, 14:55
Post: #7
RE: [Solved] [IE] Error Message: Member not found. [/IE]
This is a jQuery specific bug, as pointed out here: http://bugs.jquery.com/ticket/12577

Glad you hear you resolved it, but that's not a great fix since it basically degrades accessibility. Take a look at the above jQuery ticket for better ways to fix this.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  'too much recursion' error on hoverover with qtip 2.2.1 and jquery 1.8.2 paulred2 0 1,573 14th April 11:56
Last Post: paulred2
  Validation message for radio button hide when animate to focus ddavis 0 1,600 12th December 03:30
Last Post: ddavis
  script error on page samiloti 0 1,819 10th June 11:01
Last Post: samiloti
  Modal/Error Tip Conflict: Cannot read property 'show' of null aj_zo 0 5,120 24th October 13:47
Last Post: aj_zo
  Possible Bug: Error with show/hide and mousing over overlapping divs asdexter 4 3,666 9th October 00:26
Last Post: asdexter
  [Solved] unknown error : api.set networker 3 2,617 9th December 20:44
Last Post: Craig
  [Solved] syntax error in jquery.qtip.css mihai.niculita 3 4,405 18th November 11:40
Last Post: Craig
  [Solved] Syntax-Error Javascript missing } after property list bial 2 4,624 19th October 17:27
Last Post: bial
  [Solved] Qtip data is not defined error mutiemule 2 2,918 19th July 10:15
Last Post: Craig
  IE10 in IE7 compat mode - member not found error clearwaterstream 4 11,052 30th April 10:43
Last Post: Craig



User(s) browsing this thread: 2 Guest(s)