Please Log-in or Register to get full access to the forums.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] unwanted modal delay, when content contains image, IE8 and lower.
20th February, 11:03
Post: #1
[Solved] unwanted modal delay, when content contains image, IE8 and lower.
I have a strange bug / issue, related to an unwanted modal delay when the content contains an image, this issue only occurs in IE8 and lower.

When I remove the image, the delay is no longer present. The delay option has been omitted so would use plugin default.

The page that this issue occurs on is served via https request. If I create the same modal code on a http request page, the modal delay doesn't occur.

I'm not sure if the https/http makes a difference, I've not come across an issue like this before.

The image that is being loaded is only 806 bytes, so cannot be an issue with the image size.
Find all posts by this user
Quote this message in a reply
21st February, 04:44
Post: #2
RE: unwanted modal delay, when content contains image, IE8 and lower.
qTip2 automatically attempts to wait for images without a set height/width attribute to get dimensions before showing, to prevent it from causing a visible positioning update when displaying for the first time. Try giving your image a set height/width and this should solve the issue.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Problem in IE8 arozd 1 320 26th August 07:58
Last Post: arozd
  load different thumbnails w/ different texts in an image map? doodoonina 0 132 23rd June 06:31
Last Post: doodoonina
  [Solved] Image Map Example newshirt 4 262 9th June 20:03
Last Post: newshirt
  [Solved] api hide and hidden events fire at the same time, even with delay/effect icd2k3 1 222 20th May 12:29
Last Post: Craig
  [Solved] Image + content qtip2 mulamu├ža 3 386 24th April 19:54
Last Post: mulamu├ža
  I can't see the qtip2 in ie8 llerones 1 328 24th April 12:09
Last Post: Craig
  IE8 Object doesn't support this property or method bmz123 1 2,622 10th April 18:18
Last Post: Craig
  [Solved] Position issue with ajax modal when content is grabbed continuously twgill 1 423 15th March 13:18
Last Post: Craig
  [Solved] Image map with tooltip displayed when clicked JSnoob 8 1,534 23rd December 11:03
Last Post: NehaRana
  [Solved] Different delay for show: if mouseenter vs click steve22 1 783 9th November 16:33
Last Post: steve22



User(s) browsing this thread: 1 Guest(s)