craigsworks.com - Support Forum
[Solved] Viewport not working with absolute positioning. - Printable Version

+- craigsworks.com - Support Forum (http://craigsworks.com/projects/forums)
+-- Forum: qTip2 (/forumdisplay.php?fid=19)
+--- Forum: Help and support (/forumdisplay.php?fid=25)
+--- Thread: [Solved] Viewport not working with absolute positioning. (/showthread.php?tid=3242)



[Solved] Viewport not working with absolute positioning. - thoughtpalette - 28th February 19:27

JS Code
initializeToolTip: function () {
        $(".offer-item").each(function () {
            $(this).hover().qtip({
                content: {
                    text: 'loading...',
                    title: {
                        button: true
                    },
                    ajax: {
                        url: '/Fakepath/ToolTips/ToolTipHover',
                        type: 'GET'
                    }
                },
 
                style: {
                    classes: { tooltip: 'auction-item-tooltip' }
                },
 
                show: {
                    solo: true
                },
 
                position: {                
                    viewport: $(window),
                    target: $(this),
                    my: 'top right',
                    at: 'top right',
                    adjust: {
                        method: 'flip flip',
                        x: 280,
                        y: -20
                    }
                },
 
                hide: 'unfocus'
 
            });
        });
 
    },
 
    initializeCloseToolTip: function () {
        $('a.close-tooltip').live("click", function (e) {
            e.preventDefault();
            $(this).parents('.qtip').qtip('hide');
        });
    }


Trying to get the last element to flip sides when outside of the window to no avail. Been looking at position.container and viewport to no avail. Anybody know if I'm doing something wrong? I have 5 <article>'s with tool tips next to each other, then on the last one I want the positioning to switch to 'top left' and opposite positioning.

Any help is much appreciated. Thanks for your time! Awesome plugin btw!

Here's some SS's of whats going on.

Regular: http://i.imgur.com/bI3oR.jpg

Cut-off http://i.imgur.com/wWhyq.jpg

Thanks again!


RE: Viewport not working with absolute positioning. - Craig - 28th February 22:46

Well first make sure you're using qTip2, since that's the forum you've posted in and the syntax you're using Wink If you ARE using qTip2, then the above should work as expected.


RE: Viewport not working with absolute positioning. - thoughtpalette - 28th February 22:49

I assure you I'm using QTip2 ;}

/*
* qTip2 - Pretty powerful tooltips
* http://craigsworks.com/projects/qtip2/

In jquery.qtip.min.js

It's still not working. does the viewport option work with using the absolute positioning option?

I have this cross posted on stackoverflow http://stackoverflow.com/questions/9489209/qtip2-why-does-viewport-not-work-with-absolute-positioning

Thanks for the quick response Craig, lovely plugin.


RE: Viewport not working with absolute positioning. - Craig - 28th February 22:56

Oh sorry, I totally missed the absolute positioning part. Can you setup a test case on jsfiddle http://jsfiddle.net/fdavn


RE: Viewport not working with absolute positioning. - thoughtpalette - 28th February 23:19

(28th February 22:56)Craig Wrote:  Oh sorry, I totally missed the absolute positioning part. Can you setup a test case on jsfiddle http://jsfiddle.net/fdavn

Removed the ajax call and inner content (using Razor models) for clarity.

http://jsfiddle.net/fDavN/2761/

If you re-size the [Results] window to where all the divs line up, you can see on hover of the last one, that it doesn't re-position. :{

Let me know if there's anything else I can do to make this easier for you.

Thanks again Craig!


RE: Viewport not working with absolute positioning. - Craig - 29th February 01:06

Well the viewport positioning is working, it just seems like it isn't thanks to the adjust.x/y settings you've set! Remove those and you can see it working Smile


RE: Viewport not working with absolute positioning. - thoughtpalette - 29th February 15:23

(29th February 01:06)Craig Wrote:  Well the viewport positioning is working, it just seems like it isn't thanks to the adjust.x/y settings you've set! Remove those and you can see it working Smile

I need it at that position per the design comps :{

It's alright, apparently my lead wrote some scripts when he used your plugin on another site where it calculates the window size and flips it based on left or right. We'll probably end up using that.

Good to know viewport and absolute position don't work in tandem though!

Thanks again Craig!


RE: Viewport not working with absolute positioning. - Craig - 29th February 17:56

That's not absolute positioning though... you're just adjusting the positioning calculated by qTip? If you basically want it at the top right of the div you can achieve as you've done using the position parameters


RE: [Solved] Viewport not working with absolute positioning. - thoughtpalette - 29th February 17:59

What are the x/y coordinates for if not setting an offset/hard position? The element in theory is "absolutely" positioned based on the coordinates provided through the plugin options.


RE: [Solved] Viewport not working with absolute positioning. - Craig - 29th February 18:17

They are to "adjust" the currently calculated position, hence why it's inside the position.adjust object Wink If you want to position it absolutely i.e. set it's left/top position manually, use the syntax below, as detailed in the documentation: http://craigsworks.com/projects/qtip2/docs/position/#target
JS Code
position: {
	target: [100, 100] // [ left, top ]
}